Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Mobile site every time i login?

 
Rob Poulos
Ranch Hand
Posts: 49
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
every time i access http://www.coderanch.com/forums it seems as if i am getting the mobile site. the URL is correct for the normal site but the forum setup is is exactly the same as if i had visited http://www.coderanch.com/mobile/forums

I am using IE on my desktop PC
 
Rob Poulos
Ranch Hand
Posts: 49
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i fixed it.... kind of

i found the link at the botton of the page that says

"Or visit our non-mobile (full) site"

I clicked it and the page turned normal. but then after browsing some of the forums they are still in mobil format until i click the link again
 
W. Joe Smith
Ranch Hand
Posts: 710
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try clearing out your history/cookies/all that jazz.
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34837
369
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Rob,
It remembers your session and that you were in a mobile site until you say otherwise. Now that you've cleared it, it will stay non-mobile until you explicitly go to a mobile link again.

Disclaimer: This behavior will likely change in the future when we implement mobile browser sniffing.
 
Rob Poulos
Ranch Hand
Posts: 49
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I hope to god this isnt just me. Its still occurring. every time i come to this site now i have to click that "visit our non-mobile (full) site" link at the bottom of the page to see the regular site. I am not accessing this site via mobil phone... i never have. if i click on the link below it changes to the original site UNTIL i click on another link... then it goes back into the mobil forum. i've cleared my cache and deleted cookies..

im running Windows XP with IE8

this is aggrivating. makes me not want to visit the ranch which is rather upsetting because i like this community
 
Henry Wong
author
Marshal
Pie
Posts: 21362
84
C++ Chrome Eclipse IDE Firefox Browser Java jQuery Linux VI Editor Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Rob Poulos wrote:I hope to god this isnt just me. Its still occurring. every time i come to this site now i have to click that "visit our non-mobile (full) site" link at the bottom of the page to see the regular site. I am not accessing this site via mobil phone... i never have. if i click on the link below it changes to the original site UNTIL i click on another link... then it goes back into the mobil forum. i've cleared my cache and deleted cookies..


Works fine for me... Tried IE8, FireFox, and Chrome on XP. And IE8 and FireFox on Windows 7.

Henry
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34837
369
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've tried deleting your server session to make sure it isn't a caching issue. You'll be prompted to log in again next time you use the site.

I don't know why it would be so "sticky" though. I imagine you were on the mobile site once to comment on the layout. But it shouldn't remember that.
 
Rob Poulos
Ranch Hand
Posts: 49
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Jeanne Boyarsky wrote:I've tried deleting your server session to make sure it isn't a caching issue. You'll be prompted to log in again next time you use the site.

I don't know why it would be so "sticky" though. I imagine you were on the mobile site once to comment on the layout. But it shouldn't remember that.



This may have fixed it. from my home PC everything is looking great! but i rarely visit the ranch from my home pc so the real test will be when i go into work Monday.

if it still does it, then there has to be something wrong with the work PC. I appreciate your efforts
 
Rob Poulos
Ranch Hand
Posts: 49
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There has to be something wrong with my PC...

i clicked on the main forum page and it was the full site

I clicked on My Posts and it was the full site

I clicked on this topic and it was the mobile site again

I clicked on Reply and its the mobile site
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34837
369
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Rob Poulos wrote:There has to be something wrong with my PC...

i clicked on the main forum page and it was the full site

I clicked on My Posts and it was the full site

I clicked on this topic and it was the mobile site again

I clicked on Reply and its the mobile site

I don't know what to say. Obviously that doesn't happen on my machine!

When you say you clicked on "this" topic, the URL is the following, correct?
http://www.coderanch.com/t/479658/Ranch-Office/Mobile-site-every-time-login
 
Rob Poulos
Ranch Hand
Posts: 49
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The URL was: http://www.coderanch.com/t/479658/Ranch-Office/Mobile-site-every-time-login

I just cleared out everything again (Cache, History, Cookies, etc..). I tried to browse the forum again, this time without logging in, and the first page (http://www.coderanch.com/forums) was normal but then when i clicked on a specific forum (http://www.coderanch.com/forums/f-33/Beginning-Java) it went to the mobil view

whats weird is that it seems to be random:

I was just on http://www.coderanch.com/forums/f-33/Beginning-Java and it was the normal site

i clicked http://www.coderanch.com/t/482805/Beginning-Java/java/basic-thing-about-toString-equal and it was the normal site

i hit the back button on IE to bring me back to http://www.coderanch.com/forums/f-33/Beginning-Java and it was t he mobile site
 
Ernest Friedman-Hill
author and iconoclast
Marshal
Pie
Posts: 24212
35
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I wonder if it's not your PC at all, but rather a caching proxy at your company that is sometimes returning the wrong page. Have you noticed any cases where the mobile page is not up to date -- i.e., some posts are missing?
 
Rob Poulos
Ranch Hand
Posts: 49
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ernest Friedman-Hill wrote:I wonder if it's not your PC at all, but rather a caching proxy at your company that is sometimes returning the wrong page. Have you noticed any cases where the mobile page is not up to date -- i.e., some posts are missing?


I wasnt paying attention to that. I will keep my eye open to see if that is happening

does the site have an auto-detect feature in place? if so, maybe its how my information is being passed to it? Knowing my work, they're probably doing something to the infomation i pass.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic