• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Bear Bibeault
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Jj Roberts
  • Carey Brown
Bartenders:
  • salvin francis
  • Frits Walraven
  • Piet Souris

java.net.InetAddress is a restricted class error in Eclipse when running GWT and MySQL

 
author and cow tipper
Posts: 5000
1
Hibernate Spring Tomcat Server
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm getting the following error in Eclipse when my application tries to hit the MySQL database:



Apparently, that happens when you have enabled the Google App Engine, as the Google App Engine is supposed to handle database interactions or something (?). So, a bit of searching indicates that all will be well if you just disable the Google App Engine in Eclipse and re-run your program. So, how do you 'disable' the GAE? I can't see anything on properties, and in the Run-->Configurations window, it just says GAE is at number 1 or something, without any options to disable or enable it.

Here's the post I found on the issue:

Short Answer : Just disable Google App Engine for your project, and things
should start working. Its a setting in the Google Eclipse Plugin.
Long Answer :
GWT and Google App Engine (GAE) are two separate projects, and you don't
have to use them together.
If you enable GAE - you cannot use any other database.
If you disable GAE and only use GWT - you can use whatever you want on the
server side. Client side restrictions still apply.
Many, many users have accidentally enabled GAE (or is it enabled by
default?) and have faced this issue, so this isn't new.
--Sri


http://groups.google.com/group/google-web-toolkit/browse_thread/thread/d8c643409c8a46b7/2592d3e5165a404b?show_docid=2592d3e5165a404b

Any hints?

-Cameron McKenzie
 
Cameron Wallace McKenzie
author and cow tipper
Posts: 5000
1
Hibernate Spring Tomcat Server
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Ugh...

I removed the plugin from Preferences-->Google. Now when I run my app, I get the following error:

Unable to load server class 'com.google.appengine.tools.development.gwt.AppEngineLauncher'
java.lang.ClassNotFoundException: com.google.appengine.tools.development.gwt.AppEngineLauncher



I can now see there is a Google tab in the Properties of the Project I'm working on. Seems like you can disable the engine from there. Instead of disabling it, I managed to remove it.


 
reply
    Bookmark Topic Watch Topic
  • New Topic