This week's book giveaway is in the Kotlin forum.
We're giving away four copies of Kotlin in Action and have Dmitry Jemerov & Svetlana Isakova on-line!
See this thread for details.
Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

need help on how to recover from (possibly) broken BufferedReader  RSS feed

Reinhard Mantey
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I do some kind of batch processing and the following codefragment works 39 times and breaks at the 40th time.
Executing the batch from Eclipse, nothing strange happens - all works well.
Executing the batch from Linux-jre, it fails.

From the logging I suspect, that the code hangs in as the propietary logfile will not grow.
The result file, created by that call exists, so the execution of the process worked fine.

I tried to add some kind of watchdog (line 15-27), but nothing happens.

I think I have an error or some kind of misunderstanding, but I can't see it.
Can anybody shine me a light on how to solve that failure?
I also suspect, that the bug is related with the harddisk entering the sleepmode. But I don't know, whether the sleepmode is source or result of the bug.

Kind regards
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!