Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Eclipse of jee developer>> tomcat installation

 
Mohammad Ashrafuddin Ferdousi
Ranch Hand
Posts: 111
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How i can understand that, tomcat is already installed with eclipse gallelio? Is "tomcat" a server?
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tomcat is a web application container. I don't know if it's installed by default or not--I don't believe it is, but I always use a local installation anyway, so I wouldn't even notice if it was.
 
Mohammad Ashrafuddin Ferdousi
Ranch Hand
Posts: 111
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
David Newton wrote:Tomcat is a web application container. I don't know if it's installed by default or not--I don't believe it is, but I always use a local installation anyway, so I wouldn't even notice if it was.


So, how can i install the tomcat and configure with eclipse gallelio?
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Follow the normal Tomcat installation. When you go to add an application server in Eclipse, just point it at the Tomcat installation directory.
 
Mohammad Ashrafuddin Ferdousi
Ranch Hand
Posts: 111
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
David Newton wrote:Follow the normal Tomcat installation. When you go to add an application server in Eclipse, just point it at the Tomcat installation directory.


Thanks for your response. As i mentioned earlier, eclipes gallelio, i have already installed. I set the JAVA_HOME variable also(on windows). But when i am going to command prompt and trying to start "startup.bat" of tomcat, to start this application server, I got an error message.

The message said that: tomcat is needed to point java second edition and the java_home variable does not point that it is pointing the jre.

But i set the java_home correctly on windows. Please help me in this issue.

Thanking you
codeperl
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I can't help, you're not giving me enough information. For example, *what* did you set JAVA_HOME to.

In any case, if you're added Tomcat as a server in Eclipse you shouldn't need to set JAVA_HOME--just start/stop Tomcat from inside Eclipse.
 
Mohammad Ashrafuddin Ferdousi
Ranch Hand
Posts: 111
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
David Newton wrote:I can't help, you're not giving me enough information. For example, *what* did you set JAVA_HOME to.

In any case, if you're added Tomcat as a server in Eclipse you shouldn't need to set JAVA_HOME--just start/stop Tomcat from inside Eclipse.


Thanks for your support, sir. Ok, i am gonna describe you the procedure.

1] download apache-tomcat-6.0.24.zip.
2]unzip the file.
3]then put as: c:\apache-tomcat-6.0
4]run cmd prompt
5]then go to c:\apache-tomcat-6.0\bin command prompt and run startup.bat
6]it sends the message tomcat need to point the java se by java_home variable. and currently it points jre.
7]i go to mycomputer->properties->advanced->environment variables->click new.
8]set JAVA_HOME as C:\Program Files\Java\jdk1.6.0_17;

but same error occurs.

on eclipse, i don't do anything.

Thanks
codeperl
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You need to restart CMD in order to pick up the new environment variable, or set it from within the cmd window. And make sure the path has quotes around it since there are spaces in the path, which I try to avoid on Windows, because Windows is kind of dumb.
 
Mark E Hansen
Ranch Hand
Posts: 650
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Also, does your JAVA_HOME setting really end with a semicolon? Remove that.
You're going to have problems if you leave Java installed under a directory path that includes spaces. I would move it. I would install it in C:\Java\jdk1.6.0_17, but you can pick any location you like.
 
Mohammad Ashrafuddin Ferdousi
Ranch Hand
Posts: 111
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks i remove ";" and all works fine.

Thank you
codeperl
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic