• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Jboss failed to run on vista

 
sarada bokka
Ranch Hand
Posts: 80
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I have download jboss-5.0.1.GA.zip from the provided link http://sourceforge.net/projects/jboss/files/JBoss/JBoss-5.0.1.GA/

JAVA_HOME is set and when i tried to run the start.bat .It terminates without showing any error.

Previous I have installed on winXP using same steps .It worked fine.

Now i am trying to install Jboss on VISTA and i am unable to proceed .

Could some on help me please.
 
Kuldip Shetty
Ranch Hand
Posts: 43
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Verify the boot.log files in JBoss to see if any exception is logged at server startup.

Kuldip
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
sarada bokka wrote:

JAVA_HOME is set and when i tried to run the start.bat .It terminates without showing any error.



I guess, you mean run.bat. What did you set the JAVA_HOME to?

Post the output of

 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
 
sarada bokka
Ranch Hand
Posts: 80
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
JAVA_HOME is set to C:\installs\jdk;
JBOSS_HOME is set to C:\installs\jboss-5.0.1.GA

boot.log contains the below


Error deploying: file:/C:/installs/jboss-5.0.1.GA/server/default/conf/bootstrap/vfs.xml
at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)
at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:136)
at org.jboss.system.server.profileservice.ProfileServiceBootstrap.initBootstrapMDs(ProfileServiceBootstrap.java:453)
at org.jboss.system.server.profileservice.ProfileServiceBootstrap.start(ProfileServiceBootstrap.java:199)
at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:405)
at org.jboss.Main.boot(Main.java:209)
at org.jboss.Main$1.run(Main.java:547)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.IllegalStateException: ClassLoader has not been set
at org.jboss.deployers.structure.spi.helpers.AbstractDeploymentUnit.getClassLoader(AbstractDeploymentUnit.java:152)
at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.addBeanComponent(BeanMetaDataFactoryVisitor.java:60)
at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:126)
... 6 more

 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
sarada bokka wrote:JAVA_HOME is set to C:\installs\jdk;

1) Do not have the ";" at the end of JAVA_HOME
2) Is that where your JDK is? If yes, then set it to



(remember, no semicolon)

sarada bokka wrote:
JBOSS_HOME is set to C:\installs\jboss-5.0.1.GA


You don't have to set JBOSS_HOME

sarada bokka wrote:
Error deploying: file:/C:/installs/jboss-5.0.1.GA/server/default/conf/bootstrap/vfs.xml
at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)
at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:136)
at org.jboss.system.server.profileservice.ProfileServiceBootstrap.initBootstrapMDs(ProfileServiceBootstrap.java:453)
at org.jboss.system.server.profileservice.ProfileServiceBootstrap.start(ProfileServiceBootstrap.java:199)
at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:405)
at org.jboss.Main.boot(Main.java:209)
at org.jboss.Main$1.run(Main.java:547)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.IllegalStateException: ClassLoader has not been set
at org.jboss.deployers.structure.spi.helpers.AbstractDeploymentUnit.getClassLoader(AbstractDeploymentUnit.java:152)
at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.addBeanComponent(BeanMetaDataFactoryVisitor.java:60)
at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:126)
... 6 more



You can ignore that - it's a DEBUG message (infact i don't even think it's from the current run).

 
satya anvesh
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you tried opening the Command Prompt with "Run as administrator" ? I was not able to run Jboss before(I don't remember the exception I got) until when I tried to Run it as administrator.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Which JDK are you running> Enter:

%JAVA_HOME%\bin\java -version

and post the response.

Also, post the full command line output you get when starting the app server.
 
sarada bokka
Ranch Hand
Posts: 80
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

Thanks for your inputs

By running the command %JAVA_HOME%\bin\java -version i relaized, i have installed only JDK not JRE.

I have installed Java(jdk+jre)and the problem was sloved.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic