• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

problem with struts1.1 please help me...

 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
and in my action class im only displaying the value entered in the email...
when i invoke the jsp im the getting the following error.....


500 Internal Server Error
/TestDynaAction.jsp:

Exception thrown processing JSP page.
javax.servlet.jsp.JspException: Cannot find ActionMappings or ActionFormBeans collection
at org.apache.struts.taglib.html.FormTag.lookup(FormTag.java:798)
at org.apache.struts.taglib.html.FormTag.doStartTag(FormTag.java:506)
at jrun__TestDynaAction2ejsp13._jspService(jrun__TestDynaAction2ejsp13.java:49)
at allaire.jrun.jsp.HttpJSPServlet.service(../jsp/HttpJSPServlet.java:39)
at allaire.jrun.jsp.JSPServlet.service(../jsp/JSPServlet.java:228)
at allaire.jrun.jsp.JSPServlet.service(../jsp/JSPServlet.java:196)
at allaire.jrun.servlet.JRunSE.service(../servlet/JRunSE.java:1416)
at allaire.jrun.session.JRunSessionService.service(../session/JRunSessionService.java:1082)
at allaire.jrun.servlet.JRunSE.runServlet(../servlet/JRunSE.java:1270)
at allaire.jrun.servlet.JRunRequestDispatcher.forward(../servlet/JRunRequestDispatcher.java:89)
at allaire.jrun.servlet.JRunSE.service(../servlet/JRunSE.java:1552)
at allaire.jrun.servlet.JRunSE.service(../servlet/JRunSE.java:1542)
at allaire.jrun.servlet.JvmContext.dispatch(../servlet/JvmContext.java:364)
at allaire.jrun.http.WebEndpoint.run(../http/WebEndpoint.java:115)
at allaire.jrun.ThreadPool.run(../ThreadPool.java:272)
at allaire.jrun.WorkerThread.run(../WorkerThread.java:75)
-----------------

and the struts-config.xml and web.xml and the jsp are as follows...........................





--------------------struts-config.xml-------------------------

<!DOCTYPE struts-config PUBLIC "-//Apache Software Foundation//DTD Struts Configuration 1.1//EN"
"http://jakarta.apache.org/struts/dtds/struts-config_1_1.dtd">
<struts-config>
<form-beans>
<form-bean name="DynaForm" type="DynaForm"/>
</form-beans>

<action-mappings>
<action
path="/dynaaction"
type="DynaAction"
input="/TestDynaAction.jsp"
name="DynaForm"
scope="session"
validate="false">
<forward name="some" path="/TestDynaAction.jsp"/>
</action>

</action-mappings>

</struts-config>
--------------------struts-config.xml-------------------------

-------------------------web.xml-----------------------------------------
<web-app>



<servlet>
<servlet-name>action</servlet-name>
<servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
<init-param>
<param-name>application</param-name>
<param-value>ApplicationResources</param-value>
</init-param>
<init-param>
<param-name>config</param-name>
<param-value>/WEB-INF/struts-config.xml</param-value>
</init-param>
<init-param>
<param-name>debug</param-name>
<param-value>2</param-value>
</init-param>
<init-param>
<param-name>detail</param-name>
<param-value>2</param-value>
</init-param>
<init-param>
<param-name>validate</param-name>
<param-value>true</param-value>
</init-param>
<load-on-startup>2</load-on-startup>
</servlet>



<servlet-mapping>
<servlet-name>action</servlet-name>
<url-pattern>*.do</url-pattern>
</servlet-mapping>



<welcome-file-list><welcome-file>login.jsp</welcome-file></welcome-file-list>



<taglib>
<taglib-uri>/tags/struts-bean</taglib-uri>
<taglib-location>/WEB-INF/struts-bean.tld</taglib-location>
</taglib>

<taglib>
<taglib-uri>/tags/struts-html</taglib-uri>
<taglib-location>/WEB-INF/struts-html.tld</taglib-location>
</taglib>

<taglib>
<taglib-uri>/tags/struts-logic</taglib-uri>
<taglib-location>/WEB-INF/struts-logic.tld</taglib-location>
</taglib>

<taglib>
<taglib-uri>/tags/struts-nested</taglib-uri>
<taglib-location>/WEB-INF/struts-nested.tld</taglib-location>
</taglib>

<taglib>
<taglib-uri>/tags/struts-template</taglib-uri>
<taglib-location>/WEB-INF/struts-template.tld</taglib-location>
</taglib>

<taglib>
<taglib-uri>/tags/struts-tiles</taglib-uri>
<taglib-location>/WEB-INF/struts-tiles.tld</taglib-location>
</taglib>


</web-app>


-----------------------------web.xml--------------------------

---------------------------settting in the JRun3.1--------------------------


{default-working-folder}\WEB-INF\lib\commons-beanutils.jar
{default-working-folder}\WEB-INF\lib\commons-collections.jar
{default-working-folder}\WEB-INF\lib\commons-digester.jar
{default-working-folder}\WEB-INF\lib\commons-fileupload.jar
{default-working-folder}\WEB-INF\lib\commons-lang.jar
{default-working-folder}\WEB-INF\lib\commons-logging.jar
{default-working-folder}\WEB-INF\lib\commons-validator.jar




{default-working-folder}\WEB-INF\struts-bean.tld
{default-working-folder}\WEB-INF\struts-html.tld
{default-working-folder}\WEB-INF\struts-logic.tld
{default-working-folder}\WEB-INF\struts-nested.tld
{default-working-folder}\WEB-INF\struts-template.tld
{default-working-folder}\WEB-INF\struts-tiles.tld


-------------------------------------settings in the server--------------



---------------------------------TestDynaAction.jsp----------------------------

<%@ page language="java" %>
<%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean" %>
<%@ taglib uri="/WEB-INF/struts-logic.tld" prefix="logic" %>
<%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>

<LINK rel="stylesheet" type="text/css" href="style/styleCms.css">

<HTML>
<HEAD>
<TITLE> Dyna Action </TITLE>
</HEAD>

<BODY>
<html:form action="/dynaaction.do">
<table>
<tr>
<td><b>email  </b> </td>
<td><input type= textbox name="email" size="15" ></td>
</tr>
<tr>
<td><b>password   </b> </td>
<td><input type= textbox name="password" size="15" ></td>
<td><input type=submit name="submit" value="submit"></td>
</tr>
</table>
</html:form>
</BODY>
</HTML>
-----------------------------TestDynaAction .jsp----------------------


and if i try executing by typing the URL http://xxx.xx.xx.xx:8100/dynaaction.do then im getting the following error...


500 Internal Server Error
/dynaaction.do:

org/xml/sax/helpers/DefaultHandler
java.lang.NoClassDefFoundError: org/xml/sax/helpers/DefaultHandler
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:488)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:106)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:243)
at java.net.URLClassLoader.access$100(URLClassLoader.java:51)
at java.net.URLClassLoader$1.run(URLClassLoader.java:190)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:183)
at java.lang.ClassLoader.loadClass(ClassLoader.java:294)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:288)
at java.lang.ClassLoader.loadClass(ClassLoader.java:250)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:310)
at org.apache.struts.action.ActionServlet.initServlet(ActionServlet.java:1405)
at org.apache.struts.action.ActionServlet.init(ActionServlet.java:466)
at javax.servlet.GenericServlet.init(GenericServlet.java:258)
at allaire.jrun.servlet.JRunServletLoader.loadServletInstance(../servlet/JRunServletLoader.java:203)
at allaire.jrun.servlet.JRunServletLoader.loadServletInstance(../servlet/JRunServletLoader.java:161)
at allaire.jrun.servlet.JRunServletLoader.loadServlet(../servlet/JRunServletLoader.java:149)
at allaire.jrun.servlet.JRunSE.getServletReference(../servlet/JRunSE.java:1705)
at allaire.jrun.servlet.JRunSE.runServlet(../servlet/JRunSE.java:1231)
at allaire.jrun.servlet.JRunRequestDispatcher.forward(../servlet/JRunRequestDispatcher.java:89)
at allaire.jrun.servlet.JRunSE.service(../servlet/JRunSE.java:1552)
at allaire.jrun.servlet.JRunSE.service(../servlet/JRunSE.java:1542)
at allaire.jrun.servlet.JvmContext.dispatch(../servlet/JvmContext.java:364)
at allaire.jrun.http.WebEndpoint.run(../http/WebEndpoint.java:115)
at allaire.jrun.ThreadPool.run(../ThreadPool.java:272)
at allaire.jrun.WorkerThread.run(../WorkerThread.java:75)

IM STRUGGLING WITH THIS PROBLEM FROM THE LAST 4 DAYS PLEASE HELP ME IN OVERCOMING THIS PROBLEM IM USING STRUTS1.1 AND JRUN3.1

Thanks in advance
 
santho gundla
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,
please read the first line of the above message as...

I have written a jsp with a text field named email
and in my action class im only displaying the value entered in the email...
when i invoke the jsp im the getting the following error.....


500 Internal Server Error
/TestDynaAction.jsp:
 
Ranch Hand
Posts: 71
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

<struts-config>
<form-beans>
<form-bean name="DynaForm" type="DynaForm"/>
</form-beans>



I believe you need to spell out the full
class name to locate your form bean.

Something like:
type="org.apache.action.DynaActionForm" ....

--Nimchi
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!