Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

A service named HttpConnector already exists.  RSS feed

 
Patricia Samuel
Ranch Hand
Posts: 300
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I am implementing mule framework. While doing this i got this error
02-23 16:55:34] ERROR WebappMuleXmlConfigurationBuilder [main]: Configuration with "org.mule.config.builders.WebappMuleXmlConfigurationBuilder" failed.
org.mule.api.lifecycle.InitialisationException: Initialisation Failure: Unexpected exception parsing XML document from cuk-mule-config.xml; nested exception is java.lang.IllegalArgumentException: A service named HttpConnector already exists.
at org.mule.registry.AbstractRegistry.initialise(AbstractRegistry.java:76)
at org.mule.config.spring.SpringXmlConfigurationBuilder.createSpringRegistry(SpringXmlConfigurationBuilder.java:110)
at org.mule.config.spring.SpringXmlConfigurationBuilder.doConfigure(SpringXmlConfigurationBuilder.java:73)
at org.mule.config.builders.WebappMuleXmlConfigurationBuilder.doConfigure(WebappMuleXmlConfigurationBuilder.java:82)
at org.mule.config.builders.AbstractConfigurationBuilder.configure(AbstractConfigurationBuilder.java:39)


I have defined this entry in my mule-config
<http:connector name="HttpConnector" proxyHostname="${proxyHostname}"
proxyPassword="${proxyPassword}" proxyPort="${proxyPort}"
proxyUsername="${proxyUsername}" />

Would anyone help me in this?

Regards,
Patricia
 
raghu mrvreddy
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you try changing the name of service to HTTPConnector2 or something else. As far as I see, its not able to start the mule because it is finding two HTTPConnectors.

Let me know if this helps else can you paste your mule-config file.

Thank you,
mrvreddy
 
Patricia Samuel
Ranch Hand
Posts: 300
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Raghu,

Thanks for the reply. But when i change the HttpConnector to HttpConnector1 or whatever....it says it could not find bean name HttpConnectore. I am not able to search where this HttpConnector is defined.

Any help!!!

Regards,
Patricia
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!