[Logo]
Forums Register Login
[SOLVED] "org.hibernate.Session" ClassNotFoundException
Hello to all,

Despite I added all necessary .jar files to project, I always take boring exception warnings that say "class not found". I added the code and exception output below. I'll be so happy if someone can help me.

Thanks in advance..
With regards,
T

-----------------------------------------------------

---------------------------------------------------------

----------------------------------------------------------------
*Exception:*
What libraries are you deploying?
 
David Newton wrote:What libraries are you deploying?

I'm deploying these libraries:

  • hibernate-3.0.5.jar [for Hibernate]
  • json-lib-0.9.jar [for JSON Objects]
  • ojdbc14.jar [Oracle Driver]
  • persistence.jar [for Hibernate Reverse Engineering]


  • By the way I'm using Eclipse Galileo.
    Thanks.
    Are you deploying all the dependencies of those libraries? I thought Hibernate had a number of other dependencies.

    In any case, I'd both (a) make *sure* you're deploying the libraries you believe you are, (b) make sure the transitive dependencies are also deployed [1], and (c) turn debug logging on and check your application startup logs to determine the root cause of the failure.

    [1] http://mvnrepository.com/artifact/org.hibernate/hibernate/3.0.5
    Check the build directory of Eclipse(target e.g.) and see if the jars are copied there after the project is built.
    Thank you so much David Newton and Mustafa Garhi for your helps and recommendations.
    As you said, the problem is occured because of build path.
    With regards,
    T
    Great; glad you worked it out!
    Wink, wink, nudge, nudge, say no more ... https://richsoil.com/cards



    All times above are in ranch (not your local) time.
    The current ranch time is
    Dec 12, 2017 09:12:25.