• Post Reply Bookmark Topic Watch Topic
  • New Topic

help needed on setting up jboss  RSS feed

 
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Need help on installing jboss 6.0. I am not able to get jboss page up. just started using jboss.

what i did:
1) Downloaded jboss 6.0 from "source-forge", the file name is jboss-6.0.0.M2.
2) Unzipped it to C: , and had a "JBOSS_HOME" envi variable and also had a entry in Path to "bin" and "lib".

by the way i have Java 1.6 installed and working fine,

when i run the "run.bat", a cmd window opens and disappears in a sec. Am I missing something?
The above steps are given in "JBoss.AS.5.Development.Edition.December.2009" book.

I googled for my issue without any success.

Please help me.

Thanks,
Venkatesh





 
Sheriff
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Venkatesh Goriparthy wrote:
2) Unzipped it to C: , and had a "JBOSS_HOME" envi variable and also had a entry in Path to "bin" and "lib".


You don't have to do this 2nd step.

After downloading, you should just set the JAVA_HOME variable to point to the JDK installation home.

What have you set that to? Post the output of:

 
Venkatesh Goriparthy
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have my java 1.6 working. I am not able to set up JBOSS

for the output you asked its "C:\Program Files\Java\jdk1.6.0;"

The problem i have is with JBOSS.

Thanks for reply.

Please help me to set up jboss
 
Jaikiran Pai
Sheriff
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

for the output you asked its "C:\Program Files\Java\jdk1.6.0;"


There are 2 problems in there:

1) It's always recommended not to install Java (or JBoss) in a folder containing space in its path. Move your JDK installation to some other folder (like C:/Java/jdk1.6.0)

2) The value you have set ends with a semi-colon. It shouldn't. So if your JDK is installed at C:/Java/jdk1.6.0 then the JAVA_HOME should be:

 
Venkatesh Goriparthy
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks a million.....

Its working

and have a doubt, the previous settings as java in "program files" and ";" at end worked with Tomcat. why? just curious.
and why its not suggested to have space and why should we not have ; at end.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!