• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Jasper Reports Export to Excel not starting on column A

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am successfully using Jasper Reports, but for one major show stopper! The export reports to excel is giving me issues,
as the report starts in column B and not A

I am wondering if it is possible in jasper report to export to xls with the resulting data starting in column A and not B.
I have tried setting different JRXlsExporterParameter's but with no luck.

My code:



example

| A | B | C | D |
------------------------------------------------------------------------
| 1 | 2009/01 | true |
| 2 | 2009/02 | false |

I would like to know if anyone is getting the excel export in column A. I have a feeling this is just how Jasper Reports is.

If your exports arrive in colum b please state too.

Many thanks for any help!
 
Niknak Cooper
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Fixed.

I just added



IGNORE_PAGE_MARGINS seems to do nothing.
 
Greenhorn
Posts: 3
Oracle Tomcat Server Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
RESOLVED.

To solve this issue you need to format your page width and height to be short remove page margins.

For old Jasper tool(1.2.7)

EDIT --> Remove Margins.

For New Jasper tool (3.5.7)

Format --> remove Report Margin.

By doing like this you can remove the blank empty first column.

reply
    Bookmark Topic Watch Topic
  • New Topic