Personally I'm not a fan of inner classes but that is not a big issue. I would rename the class and method inc to something more describing because now it might be confusing because they share the same name.
"Any fool can write code that a computer can understand. Good programmers write code that humans can understand." --- Martin Fowler
Please correct my English.