• Post Reply Bookmark Topic Watch Topic
  • New Topic

regarding javadoc  RSS feed

 
Bala Gangadhar
Ranch Hand
Posts: 119
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
As part of my project i was asked to generate javadoc for the code.
I have done it using javadoc ant target.
But for most of the classes the javadoc is missing both class level and method level.
I was asked to list out for which classes and methods the javadoc comments are missing.
Easy there any simple way to generate such report or do i need manually go to every class and check it.


Thanks in advance,
Bala.
 
Campbell Ritchie
Marshal
Posts: 56584
172
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Put it into an IDE like Eclipse, tell it to throw a warning whenever documentation comments are missing, then look for the yellow triangular warning signs.
 
Bala Gangadhar
Ranch Hand
Posts: 119
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks for reply. I am using eclipse and i tried it but i couldn not. Where to set this validation. I checked at windows->preference->validations, but i could not found it..

Thanks
Bala.
 
Rob Spoor
Sheriff
Posts: 21135
87
Chrome Eclipse IDE Java Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Window -> Preferences -> Java -> Compiler -> Javadoc

You can also specify them for each project separately. Right click on a project, select Properties, and go to Java Compiler -> Javadoc.
 
Bala Gangadhar
Ranch Hand
Posts: 119
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks a lot... I have successfully generated the report for missing javadocs..

Regards,
Bala

 
Rob Spoor
Sheriff
Posts: 21135
87
Chrome Eclipse IDE Java Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You're welcome.
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!