Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

JVM_Bind with orion  RSS feed

 
Carol Murphy
village idiot
Bartender
Posts: 1211
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Anyone else have this problem? Orion used to work fine, now when I start from Command Prompt I get the address in use JVM_Bind error message. Any ideas as to why?
 
Jaikiran Pai
Sheriff
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Looks like some port which Orion (tries to) bind to is already in use. Does the JVM_Bind error show the port it's failing to bind to?
 
Carol Murphy
village idiot
Bartender
Posts: 1211
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No. Nothing that useful. The strange thing is that it tells me orion is initialized, but the console won't respond to any further input. So its just stalled and I have to restart my computer to shut down orion. I'm going to have to research this some more.
 
Carol Murphy
village idiot
Bartender
Posts: 1211
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
assigning orion to port 8080 solved the JVM_Bind problem. Now I've got to figure out why the correct index index page doesn't show up when I try to go to localhost
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!