• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

JAVA 1.5 compatibility with Solaris5.8

 
Ranch Hand
Posts: 69
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

Right now we are having JAVA 1.2 installed in our test environment and OS is Solaris 5.8

I wanted to upgrade to atleast JAVA 1.5 as now days almost all frameworks requires this.

Please suggest that whether Solaris 5.8 will support JAVA 1.5 and if not what needs to be done for the upgradation?

Please let me know about this migration process online learning resource if any!

Thanks in advance,

Ashutosh Arya
 
Ranch Hand
Posts: 152
VI Editor Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Solaris 8 (5.8) is the official build platform for Java 5 (32-bit)

When going for Java 5 you will have to register with SUN/Oracle first
because the product already announced its End of Service Life (EOSL).

If you do so, you will get a link for download and also should receive
a list of Solaris patches required (if any).

On top of that, the package manager or shell script used for installation
will check for them patches.

Java 6, just download and install.

Hope that helps
Matt
 
Ashutosh Arya
Ranch Hand
Posts: 69
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks Matt,

Can you provide me the link where I can go and register as I am not able to find the page on net!

Secondly I also wanted to ask that if I directly install java 1.5 on this version of solaris, will it work?

Thanks in advance,

Aashu
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Ashutosh Arya wrote:
I wanted to upgrade to atleast JAVA 1.5 as now days almost all frameworks requires this.



Matt Cartwright wrote:When going for Java 5 you will have to register with SUN/Oracle first
because the product already announced its End of Service Life (EOSL).



Ashutosh Arya wrote:Can you provide me the link where I can go and register as I am not able to find the page on net!



Why not go for Java 6 directly instead of going for a version which has reached EOL
 
Matt Cartwright
Ranch Hand
Posts: 152
VI Editor Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

J2SE 5.0
go here and pick the one you want

then click download and you will get to this form

provide the details and the system will send you a link for downloading the product.

Instructions for Solaris 64-bit can be found here, 32-bit Solaris instructions are here



Java 6 downloads can be found here

Hope that helps
Matt
 
Matt Cartwright
Ranch Hand
Posts: 152
VI Editor Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Ashutosh Arya wrote:
Secondly I also wanted to ask that if I directly install java 1.5 on this version of solaris, will it work?



you mean installing J2SE 5 on Solaris 8 without any previous installation of Java?

yep, will work

M
 
reply
    Bookmark Topic Watch Topic
  • New Topic