• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Tim Cooke
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Paul Clapham
  • Rob Spoor
  • Junilu Lacar
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
  • Carey Brown
Bartenders:

model.addAttribute value won't display using JSTL in my jsp file

 
Ranch Hand
Posts: 109
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I event tried to pass something generic like



And when I try to display the result like such:



What displays is actually ${name} instead of me

I do have the jstl library in my webapp and I did include the following line of code in my jsp file <%@ taglib prefix="c" uri="http://java.sun.com/jsp/jstl/core" %>

I'm not sure what I'm doing wrong.
 
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Make sure that your web.xml is defined correctly. Check this FAQ.
 
laura mccord
Ranch Hand
Posts: 109
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Ugh! That was it!

I have been doing various samples and I must have meshed them without considering the a conflict in versions.

Thanks sooooo much...now I can proceed.

Laura
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic