Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem deploying EAR file

 
Samantha Morgan
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi guys!!!

Gotta problem... when I'm deploying ear file I got this error

-----------------------------------------------------------
[INFO] PropertyMessageResources - -Initializing, config='org.apache.struts.util.
LocalStrings', returnNull=true
[INFO] PropertyMessageResources - -Initializing, config='org.apache.struts.actio
n.ActionResources', returnNull=true
[ERROR] Digester - -Begin event threw exception <java.lang.reflect.InvocationTar
getException>java.lang.reflect.InvocationTargetException: java.lang.NoClassDefFoundError: org/apache/struts/action/ActionForm
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:488)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:106)

-----------------------------------------------------------

All the classes are in my WEB-INF/lib folder and so in the proyect classpath... If I deploy my war file, it doesn't show up this error, in fact it deploys well. Deploying jar file doesn't show the error either...


I'm running in Weblogic6.1, and Struts 1.1


So, please.. if somebody can help me with this issue I would really appreciate that...

Thanks in advanced

Sami
struts_user2003@yahoo.com
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic