• Post Reply Bookmark Topic Watch Topic
  • New Topic

@Preconstruction is being ignored

 
Ganesh Podaralla
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am using JSF1.2 with JBoss 5.1.0-GA server. I am trying to use @Preconstruction on one of my methods but it is not being invoked. I verified that the web-app servlet version is 2.5 and the faces-config JSF version is 1.2. Even I tried using the context-param with JBoss InjectionProvider (JBossInjectionProvider) and Tomcat Injection Provider (WebContainerInjectionProvider) as below.

<context-param>
<param-name>com.sun.faces.injectionProvider</param-name>
<param-value>org.jboss.web.jsf.integration.injection.WebContainerInjectionProvider</param-value>
</context-param>

Please let me know if you have any ideas to fix this issue.
 
Ganesh Podaralla
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Oops..sorry, I placed incorrect context-param in my previous post. The below are the cotext-params I used.

<context-param>
<param-name>com.sun.faces.injectionProvider</param-name>
<param-value>org.jboss.web.jsf.integration.injection.JBossInjectionProvider</param-value>
</context-param>


<context-param>
<param-name>com.sun.faces.injectionProvider</param-name>
<param-value>com.sun.faces.vendor.WebContainerInjectionProvider</param-value>
</context-param>
 
Ganesh Podaralla
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I guess I am lost identifying the solution for this issue. There are typos in my first post.

The annotation I am trying to make it work is @PostConstruct, not @PreConstruction
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!