• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Commons-net FTP and AIX 5.3 FTP Server

R. Duval
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello folks,

I've been facing an awkward problem regarding commons-net and an AIX 5.3 FTP server which I'll try to explain below.

I have no problems connecting and uploading files to Linux, Windows or even SCO (yes, it still exists) FTP servers, but when I try to execute a simple command using FTPClient to AIX 5.3 I got the following exception:

The code that generates the stack above is just that:

That was intriguing, so I performed some research and reached the following results printing all responses from the server while was just trying to list some folder files:

And these are the sysout results:

Some additional data may be useful:
  • There is no firewall between the client and the FTPServer
  • I've tried other client libraries (like edtFTPJ, ftp4j), they work but their performance is very poor compared to commons-net
  • I couldn't find an explicit way to set preference on ipv4 stack over ipv6 stack in commons-net lib

  • I've also tried to enable the remote passive mode for no avail. Tried several different things, like disabling the remote verification, and nothing made the trick. It's a very specific problem, but any thoughts would be greatly appreciated.

    Thanks in advance
    • Post Reply
    • Bookmark Topic Watch Topic
    • New Topic