• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Liutauras Vilda
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Piet Souris
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
Bartenders:
  • Himai Minh
  • Carey Brown
  • Frits Walraven

Problems replying to thread

 
Bartender
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I can't seem to be able to add a response to this thread: Swing Thread. Is it me? My connection? The Thread? The forum?
 
pete stein
Bartender
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Testing if I can reply to this thread...
 
author & internet detective
Posts: 40685
827
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Seeing if a small change helps.
 
Jeanne Boyarsky
author & internet detective
Posts: 40685
827
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Oh good. We seem to have a workaround.
 
pete stein
Bartender
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks (I think), it works now. What happened?
 
Jeanne Boyarsky
author & internet detective
Posts: 40685
827
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

pete stein wrote:Thanks (I think), it works now. What happened?


Well we had a deployment a couple hours before you started this thread so clearly something changed in the code broke the forum. The funny thing is that I posted in the twitter thread to confirm all was well. What I didn't do was confirm it posted!

I'm not sure specifically what the error is. I do know what area of the code so I was able to create a workaround. Rather than speculate, I'd rather wait for the person who worked on that code to look at it. Since we are up, it isn't as pressing now.
 
author and jackaroo
Posts: 12199
280
Mac IntelliJ IDE Firefox Browser Oracle C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Mea culpa

I had made a change to the format of emails that are sent out to members who have requested updates on a topic or a forum. Unfortunately I left out a null pointer check in the change, and a NPE trickled up the system, stopping the "post message" workflow from completing.

I know what the problem is, and I am working on a long term solution.
 
pete stein
Bartender
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Andrew Monkhouse wrote:Mea culpa

I had made a change to the format of emails that are sent out to members who have requested updates on a topic or a forum. Unfortunately I left out a null pointer check in the change, and a NPE trickled up the system, stopping the "post message" workflow from completing.

I know what the problem is, and I am working on a long term solution.



Thanks for the update. Look, if you need anyone to put bugs into your code then I'm your man since that's one thing that I know I'm good at!
 
reply
    Bookmark Topic Watch Topic
  • New Topic