Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

ERROR convention.PackageBasedActionConfigBuilder - Unable to load class

 
Nandish Sri
Ranch Hand
Posts: 45
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am getting the below error in server. I hosted this application in server. There getting below error, but in local it is working fine.
And in the error, its logging something strange which is not related to my application at all..
Is it related to conflicting with some other application on the server with same namespace ???
I am trying to solve this issue since 2 days.. Anyone please help me.....

struts.xml

Here is the error:


Web.xml


Libraries:
 
Nandish Sri
Ranch Hand
Posts: 45
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please see struts.xml in above post. I am using customized interceptor stack. Is there any problem with that usage ? I am confused. The same application is working perfectly in my local system. I am using same tomcat version 6.0 as in server, but error only in server. This is strange.... I am blank on this.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If those com.careerChapter classes aren't yours, you'll probably have to turn off some of the convention plugin's package scanning--although they must be *somewhere*, otherwise they wouldn't be being scanned. Are you intending to use the convention plugin?

It's also possible that it's a different app deployed on the same server and the messages aren't related in any way to your application.

Why do you define a Struts 1 taglib in your web.xml?
 
Nandish Sri
Ranch Hand
Posts: 45
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks David for your response.
I am not sure, why I am using convention plugin. Shall I remove struts2-convention-plugin-2.1.6.jar from my application or is it referring somewhere internally ?
And in web.xml, struts1 you mean, referring of logic tags ? I will remove struts.jar also, not sure why I am using this older and newer version both !
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you're not using the convention plugin you should remove it.

Struts 2 plugins can alter behavior, sometimes in unexpected ways: if you *intend* to use it, that's fine, but it's most likely what's causing the problem, as I mentioned previously.
 
Nandish Sri
Ranch Hand
Posts: 45
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks David. Your solution resolved my issue. I removed convention plugin jar file. Thanks a lot.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Glad you figured it out :)
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic