Win a copy of Fixing your Scrum this week in the Agile forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Rob Spoor
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Junilu Lacar
  • Tim Cooke
Saloon Keepers:
  • Tim Holloway
  • Piet Souris
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Frits Walraven
  • Himai Minh

Starting and Stopping JBoss server in ANT script in Solaris Environment

 
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I am connecting Solaris machine throght putty. I have to start and stop the JBoss Server through ANT Script. The server should started in new putty while calling the target start_server. Please help me on this for the Solaris Environment. In My Current Script I am not able to start the JBoss server automatically while calling the target.
Here is the script.




Please help me especially in Solaris environmet. We are doing it in local JBoss Windows environment successfully.
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
First, please use code tags when posting source. I modified your post for you this time.

Second, I assume that the Ant script is being run on the remote Solaris machine within the ssh session, is that correct? (In other works, your Ant script is not local to your PC.)

Finally, saying "I am not able to start the JBoss server" does not help. When you run the script, what happens? What output are you getting (please post it!)

Also, it looks yoiu are running several scripts (twedos2unix.sh, starttweapplication.sh). Without knowing what those do, how do you expect us to be able to help you?
 
Ramkumar Nachimuthu
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
Thanks for your reply. While calling this target nothing is happening and it seems JBoss is not running becoz i checked with URL and welcome page is not coming.

Ant script is in remote machine(solaris) only and i am accessing with Putty and WinSCP. here we tried to create a temp file and put dos2unix command to start. But it is not working.

Kindly send me the start script to start the JBoss server. If possible please send me the fresh script.

Thanks
Ramkumar.
 
Peter Johnson
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Try running the ant script with the -v option, and post the full output, including the command you entered.

For a script to run JBoss AS, look at jboss_home/bin/run.sh
 
Popeye has his spinach. I have this tiny ad:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic