Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Struts2-jquery-plugin 2.1 jsp err:Cannot find the tag library descriptor for "/struts2-jquery-tags"

 
David Brave
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, Im having a problem with the new struts2-jquery-plugin-2.1

I follow the website http://code.google.com/p/struts2-jquery/ to figure out how to run the new version of the plugin.
They say to just add the struts2-jquery-plugin-2.1 to your lib folder then make sure to reference tag in your jsp page as such:

<%@ taglib prefix="sj" uri="/struts2-jquery-tags" %>

But I get an error with this tag that says Cannot find the tag library descriptor for "/struts2-jquery-tags".

The old struts2-jquery-1.2 plugin worked with my struts2 projects, but now i get this funny error.

I have my functional struts2 project. If im using the old struts2-jquery-plugin1.2 then the
<%@ taglib prefix="sj" uri="/struts2-jquery-tags" %> tag doesnt have any errors associated with it, but
If i add the struts2-jquery-plugin2.1 instead then I get the error associated with the "/struts2-jquery-tags"

Does anyone have any idea on what might be wrong here? Other people are using this, so I want to know
why they didnt run into this problem.

Please help.

dave
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It'd be best to ask the creator of that project, really.

That said, all the example JSPs use a different URI than you're using--you might want to try the one its examples use (and as shown on the project's home page).
 
Glen Divers
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
David Pew wrote:Hi, Im having a problem with the new struts2-jquery-plugin-2.1

I have my functional struts2 project. If im using the old struts2-jquery-plugin1.2 then the
<%@ taglib prefix="sj" uri="/struts2-jquery-tags" %> tag doesnt have any errors associated with it, but
If i add the struts2-jquery-plugin2.1 instead then I get the error associated with the "/struts2-jquery-tags"


I'm using the 2.1 plugin and I think you'll find the relevant incantation is <%@ taglib prefix="sj" uri="/struts-jquery-tags"%>

Regards
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic