Win a copy of Penetration Testing Basics this week in the Security forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Initializing TilesPlugin

Markus Staab
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I want to use tiles in my application, however, I get an error message when the TilesPlugin initializes:

<04.11.2004 10.52 Uhr CET> <Warning> <Net> <BEA-000905> <Could not open connection with host: and port: 80.>
2004-11-04 10:52:35,859 [main] ERROR org.apache.struts.tiles.TilesPlugin - Can't create Tiles definition factory for module ''.
<04.11.2004 10.52 Uhr CET> <Error> <HTTP> <BEA-101216> <Servlet: "action" failed to preload on startup in Web application: "application".
javax.servlet.ServletException: IO Error while parsing file '/WEB-INF/tiles.xml'. Tried all: '1' addresses, but could not connect over HTTP to server: '', port: '80'

I added the taglib to my web.xml:

The plug-in is defined in the struts-config.xml:
<plug-in className="org.apache.struts.tiles.TilesPlugin" >
<set-property property="definitions-parser-validate" value="false" />
<set-property property="definitions-config" value="/WEB-INF/tiles.xml" />

As far as i can tell, the tiles.xml is also valid:
<?xml version="1.0" encoding="ISO-8859-1" ?>
<!DOCTYPE tiles-definitions PUBLIC "-//Apache Software Foundation//DTD Tiles Configuration//EN" "">

I'm using Struts 1.2.4 on WebLogic 8.1

Thanks for your help.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic