• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Jsp and Apache commons upload

 
frank braunstein
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Good evening,
I hope there is someone in this Forum who can help me. I'm trying this -Using FileUpload- tutorial since yesterday, which explains how to use the Apache-Commons-fileupload-API. Unfortunately after doing everything as described by the tutorial i get a blank page to see. This is my servlet-code:

Before you start telling me its the web.xml that is configured wrongly, i tell you that commenting out things like this:

prints the outer out-println. So it has something to do with . But i don't know exactly what goes wrong when the server executes that line of code. Any hints strongly appreciated. Ah, of course this is the corresponding html-file.

As you can see the enctype is set, as is the file-type.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Anything in the logs?
 
frank braunstein
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hold everything. In the tutorial's first paragraph "Using FileUpload" the author has mentioned some dependencies with Apache's commons-IO library. After adding this library to my classpath it seems to work, but i still cant iterate over the request's item's. But the topics question is resolved.

UPDATE:
The step above actually solved the problem and a exclamation mark in the if statement.

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic