Win a copy of The Way of the Web Tester: A Beginner's Guide to Automating Tests this week in the Testing forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Loopback Url Troubleshooting

Bill Riedl
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
I have configured a centos 5.4 virtual box to run the liferay portal manager on a Glassfish v2.1 application server. Even though this is not recommended I gave glassfish root privileges and am allowing to listen on port 80.(I did this because of a nightmarish experience with mod_jk although the behavior that was frustrating there is the same behavior I describe below so if I fix this I can go back to an apache front !!) It works locally using the servers ip address in a browser "" the liferay welcome screens comes up without delay. However when I try to access the host using its domain name from a web browser not on the internal network the following happens.
I enter "" and get this --> "" There is some type of loopback error

I do believe this pertains to my glassfish install because when I stop glassfish and start apache I can navigate to "" and see the standard apache "It works!" splash page with no unexpected behavior.

To be complete I added a third http-listener to glassfish which binds port 80 and is set to listen at which is the glassfish shorthand for listening on any IP address bound to the host.

Lastly, I have completely redone iptables with a complete flush and then added the necessary rules back to ensure there was not any redirection occuring.

Thanks for your time! I am stumped on this one!
-JavaEE Newb Bill
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic