This week's book giveaway is in the Beginning Java forum.
We're giving away four copies of Get Programming with Java (MEAP only) and have Peggy Fisher on-line!
See this thread for details.
Win a copy of Get Programming with Java (MEAP only) this week in the Beginning Java forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Bear Bibeault
  • Knute Snortum
  • Liutauras Vilda
Sheriffs:
  • Tim Cooke
  • Devaka Cooray
  • Paul Clapham
Saloon Keepers:
  • Tim Moores
  • Frits Walraven
  • Ron McLeod
  • Ganesh Patekar
  • salvin francis
Bartenders:
  • Tim Holloway
  • Carey Brown
  • Stephan van Hulst

Can we point IBM WebSphere Application Server - Express, 6.0.2.19 to JDK 1.5 instead of JDK 1.4.  RSS feed

 
Ranch Hand
Posts: 31
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

I developed a full application in JDK 1.5 and now I come to know then my client is using IBM WebSphere Application Server - Express, 6.0.2.19 which points to JDK 1.4.
So, on deploying my application, it throws UnsupportedClassVersionError exception.

So how can we point this application server to JDK 1.5 so that my application can run without any problem?

Note:
I am using this URL for Administrative Console: http://10.1.0.3:9060/ibm/console/
where 10.1.0.3 is ip of the sytem where this application sever is installed.

Thanks
Mohnish
 
Ranch Hand
Posts: 446
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I would suggest you stick to the JDK version that is supported by WAS version. I have experienced WAS 6.x and 7.x and played with JDK/JRE and my experience tells me to stick to what is bundled with that specific IBM product.
 
Ranch Hand
Posts: 90
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi mohnishi,

I would like to share my experience. I had faced this problem in my previous application.I have implemented a application using jdk1.6 but i need to deploy this application in was 6.0 which is stick to jdk1.5.At that time i approached an Architect.He suggested me ,it is better to use product in built version(jdk 1.5).So i had changed my code for jdk1.5.
 
Do the next thing next. That’s a pretty good rule. Read the tiny ad, that’s a pretty good rule, too.
RavenDB is an Open Source NoSQL Database that’s fully transactional (ACID) across your database
https://coderanch.com/t/704633/RavenDB-Open-Source-NoSQL-Database
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!