Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Issues in sending mail using JavaMailSender

 
sivachithambaram Rangaraj
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

I am using JavaMailSender to send a mail .Mail is received to the correct destination ,But the body of email contains unwanted header informations like

------=_Part_8_19791179.1276263086968
Content-Type: multipart/related; boundary="----=_Part_9_5263030.1276263086968"

------=_Part_9_5263030.1276263086968
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit


Dear Applicant1,

Please find your account details below,

User Name : Applicant1
Password : BP^9^0uN

Kindly note that this is a system generated password and do remember to change this password when you login for the first time.

Warm Regards,
Jupiter Admin
------=_Part_9_5263030.1276263086968--


and also in the mail "to" address and "subject" of the mail is not populated.It looks like some issues related to the configuration.But i coudn't figure out the exact reason.The JavaMailSender has the following configuration
port=25
host=local
smtp.auth=false
mail.smtp.starttls.enable=false.


Any help will be highly appreciated.



 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Without the code that creates the email I don't see how anybody could help.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic