I have JBoss environments which are running v4.0.4, v4.0.5 and v4.2.2 and Java 5. I need to upgrade these environments to Java 6 and things are not working (specifically problems with web services).
I found in the JBoss 4.2.3 Readme the first mention of Java 6 support and it mentioned certain libs needed to be copied from jboss\client to the endorsed directory. (Another site mentioned something similar in order to get the classloader to load things from these libs before others.) My versions of JBoss don't have these same named files but I've tried to figure it out w/ no luck.
1) Can the versions of JBoss I have even run in Java 6 - 4.0.4, 4.0.5 and 4.2.2 - or for some versions is this simply not supported?
2) Is it documented somewhere how to do this - for each version?
3) If not, has someone done this successfully and if so, how?
It may be possible to figure out how to apply a similar patch to versions before 4.2.x. However, the JBoss site states that if someone asks for help debugging a problem in an unsupported environment (e.g., 4.0.x + Java 6), if downgrading to Java 5 fixes the problem, that is the fix.
a) Is it because you are deploying to JBoss AS 4.0.x an app that requires JDK 6?
b) Or it that some other app running on the same system needs JDK 6?
c) Or is it a JDK support issue (versions below 6 no longer being supported)?
If the answer is "b", you can install multiple JDKs and run JBoss AS 4.0.x with an older version and run other apps with a newer version (I have JDKs going all the way back to 1.3.1 on my PC).
customer desire to have java 6 app (which runs in the jboss versions i've mentioned). the customer has been informed of the compatibility issues and is fine staying with java 5 until we can upgrade all jboss environments to a version that supports it.
customer desire to have java 6 app (which runs in the jboss versions i've mentioned).
This makes no sense - this sentence implies that the app is already running in AS 4.0.x with JDK 6 and that it works just fine! I assume what you meant to say is my option "a" - the app requires JDK 6 and you would like to deploy it to 4.0.x (and 4.2.2).
is fine staying with java 5
This is contradictory to your statement that the app is a "java 6 app" which implies that Java 6 is required to run it. How can an app that requires Java 6 run on 5?
I guess what you are really saying is that the customer would like to use Java 6 but that the app requires at least Java 5. Is this a correct assumption?