• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

do earlier versions of jboss support java 6 - help!

 
Ranch Hand
Posts: 109
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

I have JBoss environments which are running v4.0.4, v4.0.5 and v4.2.2 and Java 5. I need to upgrade these environments to Java 6 and things are not working (specifically problems with web services).

I found in the JBoss 4.2.3 Readme the first mention of Java 6 support and it mentioned certain libs needed to be copied from jboss\client to the endorsed directory. (Another site mentioned something similar in order to get the classloader to load things from these libs before others.) My versions of JBoss don't have these same named files but I've tried to figure it out w/ no luck.

1) Can the versions of JBoss I have even run in Java 6 - 4.0.4, 4.0.5 and 4.2.2 - or for some versions is this simply not supported?
2) Is it documented somewhere how to do this - for each version?
3) If not, has someone done this successfully and if so, how?

All immediate help is greatly appreciated!
Kelly
 
Kelly Dolan
Ranch Hand
Posts: 109
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I continued to search and found some answers.

Essentially versions before 4.2.x do not support Java 6 and 4.2.x versions require a patch.

Compatibility Matrix - http://community.jboss.org/wiki/JBossWithJDK6
Assumed 4.2.x patch - http://www.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/4.3.0.cp08/html/JDK6_Compatibility_Notes/index.html


It may be possible to figure out how to apply a similar patch to versions before 4.2.x. However, the JBoss site states that if someone asks for help debugging a problem in an unsupported environment (e.g., 4.0.x + Java 6), if downgrading to Java 5 fixes the problem, that is the fix.
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
What is the reason for upgrading to JDK 6?

a) Is it because you are deploying to JBoss AS 4.0.x an app that requires JDK 6?
b) Or it that some other app running on the same system needs JDK 6?
c) Or is it a JDK support issue (versions below 6 no longer being supported)?

If the answer is "b", you can install multiple JDKs and run JBoss AS 4.0.x with an older version and run other apps with a newer version (I have JDKs going all the way back to 1.3.1 on my PC).

 
Kelly Dolan
Ranch Hand
Posts: 109
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
customer desire to have java 6 app (which runs in the jboss versions i've mentioned). the customer has been informed of the compatibility issues and is fine staying with java 5 until we can upgrade all jboss environments to a version that supports it.
 
Peter Johnson
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

customer desire to have java 6 app (which runs in the jboss versions i've mentioned).


This makes no sense - this sentence implies that the app is already running in AS 4.0.x with JDK 6 and that it works just fine! I assume what you meant to say is my option "a" - the app requires JDK 6 and you would like to deploy it to 4.0.x (and 4.2.2).

is fine staying with java 5


This is contradictory to your statement that the app is a "java 6 app" which implies that Java 6 is required to run it. How can an app that requires Java 6 run on 5?

I guess what you are really saying is that the customer would like to use Java 6 but that the app requires at least Java 5. Is this a correct assumption?
 
Kelly Dolan
Ranch Hand
Posts: 109
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
app is running in jboss already but is java 5. customer wants to move to java 6.
 
I don't even know how to spell CIA. But this tiny ad does:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic