Win a copy of Five Lines of Code this week in the OO, Patterns, UML and Refactoring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

SCWCD Exam and Book Queries

 
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I'm planning to give SCWCD 1.5 and I had a couple queries..

I've already given SCJP 1.4 long time back (some 3-4 years ago may be). One friend had told that I'd need to give upgrade exam of SCJP first. I checked on the Sun Certification site and from what I understood, that's not really the case.. Any edition of SCJP is OK for giving SCWCD 1.5. Please correct me if I'm wrong.

Also, I have Head First Servlets and JSP 1.4 book, I'd bought it long time back, but couldn't quite make time to prepare.. I've just started to prepare again and I wanted to know - is that book enough or should I trade that one for newer version? Are there a lot of differences?

Please advice. Thanks in advance!
 
Ranch Hand
Posts: 112
Eclipse IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You will need 1.5 version of the book.There are many changes.
 
Ranch Hand
Posts: 310
1
Oracle Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Roshni, As far as I know any version of SCJP is good enough for taking SCWCD. Please check here for differences between SCWCD 1.4 and SCWCD5 exam. The link answers whether you can use HFSJ 1.4 to appear for SCWCD5 exam (answer from Bryan Basham!) Good luck!!!
 
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

One friend had told that I'd need to give upgrade exam of SCJP first.


No. As Rajeev said, any version will do. You may have to know some basics about generics and enhanced for-loops though.

is that book enough or should I trade that one for newer version? Are there a lot of differences?


There are not many differences. You should be fine with that book. But you'll need to check this tutorial about dynamic attributes. There are also a lot of good links here that you should check.
 
Roshni Singhania
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Thanks all of you for responding.. and Christophe and Rajeev, thanks a lot for those links.. they're very helpful.

I have targeted Jan 2011 for giving the exam.. hope to be able to meet the target!

 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Good luck. Anytime you have a doubt, don't hesitate to ask questions here
 
if you think brussel sprouts are yummy, you should try any other food. And this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic