• Post Reply Bookmark Topic Watch Topic
  • New Topic

JSF tag in Tomcat 6.0.28

 
Vincent Zhao
Greenhorn
Posts: 28
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There is a JSF web application which runs fine on Tomcat 6.0.16 and 6.0.18. I need migrate to Tomcat 6.0.28, but I ran into problems.

In my test JSP page:



When I deployed to Tomcat 6.0.16, it runs fine.

But when I deployed to Tomcat 6.0.28, it produces:

#{bundle.title}

There are no error messages in logs.
 
Vincent Zhao
Greenhorn
Posts: 28
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Resolved by following this thread:
Link

by Konstantin Kolinkoon 2010-03-12T21:00:10+00:00.
2010/3/12 Sai Pullabhotla
I have just downloaded trinidad-1.2.13-example.zip and
its trinidad-demo-1.2.13.war works for me in 6.0.26.
Cannot find usable tomahawk or richfaces examples:
tomahawk-examples-1.1.8-bin.zip is for MyFaces 1.1 / Servlet 2.4,
irrelevant here
richfaces-examples-3.3.2.SR1.zip (photoalbum) requires JBoss
In short, parsing in Tomcat 6.0.26 was made more strict to the version
of specification that your web application, your tag library and the
tag that you are calling are using.
The change was to address bug 48668. Most likely this commit is what
affected you:
http://svn.apache.org/viewvc?rev=920916&view=rev
Please make sure that
1) Your web.xml adheres to the Servlet 2.5 specification
I.e., starts with

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
http://java.sun.com/xml/ns/javaee/web-app-2-5.xsd"
version="2.5"
2) The TLD file for the tag library that you are using adheres to the
JSP 2.1 specification.
Yes, that is JSP 2.1
Note, that
web.xml, make sure that
looking on the actual TLD file that was used.
Best regards,
Konstantin Kolinko
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!