• Post Reply Bookmark Topic Watch Topic
  • New Topic

Wierd SOAP error while Authenticating in web services

 
Karthik Krishnamurthy
Ranch Hand
Posts: 118
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am having a wierd issue while authenticating in my Webservices. A specific username (bostws) is causing an error: I am using SopaUI 2.5.1 and my server is jboss.

My request is as follows:



If I use a different LoginID and wrong password, I get a proper "Authentication Failed" error. However, with this specific login id (bostws) I am getting the following error: Please Help!!!
 
Karthik Krishnamurthy
Ranch Hand
Posts: 118
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Just asking again if anyone has an idea. I am really stuck and unable to proceed here!

Thanks
Karthik
 
R Srini
Ranch Hand
Posts: 215
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi. I have not worked with JBoss (and this problem may have nothing to do with JBoss), but maybe we can look into this together. A couple of questions:

1. Have you looked at the server logs when you invoke the web service? Can you post some of the relevant lines? Maybe there is a null pointer exception on the server side?
2. Are you using a specific type of authentication? Or are the LoginID and Password tags internal to your application?
 
Karthik Krishnamurthy
Ranch Hand
Posts: 118
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Srini,
Thanks for the hint. I looked further into our permission logs, and looks like that user's password had expired, and somehow this information did not get passed into the exception.

Thank you very much once again.

Karthik
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!