Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Exception while loading the validation.xml in strusts

 
subhash kumar
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
I am getting the following exception trace while loading the validation.xml in validation framework of struts :


any suggestion will be highly apreciated.
 
Ankit Garg
Sheriff
Posts: 9528
33
Android Google Web Toolkit Hibernate IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you post your validation.xml file...
 
Fidel Edwards
Ranch Hand
Posts: 234
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Subhash,

The error mentioned in Stack Trace is self-explanatory. You can see it clearly says the


It means that your validation.xml was not properly loaded by Container.

Always try to use (or copy) all xml and jar files from Struts-blank.war (version specific). It will help you a lot as you will no need to bother about the DOCTYPE in XML and jar files version.

Regards,

Fidel
 
subhash kumar
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
here is the validation.xml(i have copied from the internet)

 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What version of commons validator are you actually using?
 
subhash kumar
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i am using commons-validator-1.3.1
but i think version mismatch problem is there.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well yeah, your XML file indicates an older version.
 
subhash kumar
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes problem was the version mismatch.
I downloaded all components of struts of the same version and it worked successfully



This topic is resolved.

Ankit, Fidel, David Newton

Thanks a lot for the suggestions.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Glad you worked it out!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic