Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Websphere needs restart for the JNDI lookup to work!

 
Essam Fayez
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello, I'm using RAD 7.5 and connected to a remote WAS 7 Server.
I'm developing a Web Application that retrieves data from an SQL Server 2005. I already did set up the JDBC and i use the JNDI to connect.
So far everything is working GREAT!
The only problem i'm facing is that from time to time the JDNI lookup fails!
but as soon as i restart the server, everything works fine again!
I tried to figure the reason behind this problem but i couldn't!
Could anyone please help?!
 
Jan Cumps
Bartender
Posts: 2602
13
C++ Linux Netbeans IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am moving this post to our Websphere forum for you.
The only problem i'm facing is that from time to time the JDNI lookup fails!
Can you tell us how you know it fails? What happens? Do you get an error message?
 
Essam Fayez
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Jan Cumps wrote:I am moving this post to our Websphere forum for you.
The only problem i'm facing is that from time to time the JDNI lookup fails!
Can you tell us how you know it fails? What happens? Do you get an error message?

To be honest I can't give you specific details cause i just restarted the server minutes ago, so it's working fine right now.
The way I used to determine that the lookup failed was by handling the exception and display for example "Lookup failed"
I'll post the message that the browser displays as soon as the application fail again
Thanks alot for helping
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic