Win a copy of Reactive Streams in Java: Concurrency with RxJava, Reactor, and Akka Streams this week in the Reactive Progamming forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Ganesh Patekar

cewolf PieEnhancer

 
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hie guys,
I'm having an issue with my pie charts . When I'm reporting on a small number of data items the labels look neat but when I report on about ten data items that have descriptions that are more that 10 characters long while using PieEnhancer attribute <cewolf:param name="simpleLabels" value="false" />, these descriptions begin to be wrapped into the label text boxes in a manner I cannot control , as well as these label text boxes appearing to be overlapping each other such that you cannot make out anything from the information contained in the text boxes.
The appearance with <cewolf:param name="simpleLabels" value="true" /> is worse as some labels are completely overlapped as they appear one over the other but the dimesions here allow have a longer length to display the labels.
Is there a way to change the dimensions of the labels (label text boxes) so that they do not overlap and appear crowded on a pie chart using a post processor and can I enforce a gap between the labels.
If this is not possible I will be forced to drop these pie charts from my reports.
Please assist.
 
Rancher
Posts: 43011
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
One solution would be to make the chart wider - that way the labels will be wider, and won't wrap (assuming simpleLabels=false).

Another solution might be not to have any labels in the chart itself, but instead to use a separate legend (which could be on any of the sides of the chart, or be a completely separate image).
 
Levi Raymond
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Ulf for your response. How do I disable the labels from displaying on the pie chart as this seems like the a default feature?
 
Ulf Dittmer
Rancher
Posts: 43011
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Good question :-) Try the PieEnhancer that comes with cewolf-1.1.2; it has a <cewolf:param name="showSectionLabels" value="true/false"/> attribute.
 
Levi Raymond
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks, it worked.
 
Creativity is allowing yourself to make mistakes; art is knowing which ones to keep. Keep this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!