Win a copy of Microservices Testing (Live Project) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Eclipse Help Menu no longer has link to Welcome Panel

 
Ranch Hand
Posts: 94
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I believe that it existed at one time. Is there a way to configure the Eclipse Help Menu?
 
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Which version are you using ? It's there in Helios. Help -> Welcome.
 
Robert Heath
Ranch Hand
Posts: 94
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Christophe Verré wrote:Which version are you using ? It's there in Helios. Help -> Welcome.



I am using 3.5.2. Somehow the Welcome menu item has been removed from the Help Menu. I was wondering if there was some kind of menu parameter that has been reset.
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Strange. I don't know why it's not there in your Galileo installation. I also have Galileo installed on my machine, the "Eclipse IDE for Java Developers" distribution. It's there. Can you check the following :

Go to Window->Customize Perspective->Menu Visibility->Help. Is the Welcome check box ticked ?
 
Robert Heath
Ranch Hand
Posts: 94
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Christophe Verré wrote:Strange. I don't know why it's not there in your Galileo installation. I also have Galileo installed on my machine, the "Eclipse IDE for Java Developers" distribution. It's there. Can you check the following :

Go to Window->Customize Perspective->Menu Visibility->Help. Is the Welcome check box ticked ?



There is no check box for Welcome. Is there an xml file for this dialog?
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Robert Heath wrote:There is no check box for Welcome.


I almost laughed Before looking for any XML file, it might be that the necessary plugin is not installed.
Go to Help->About Eclipse->Installation Details->Plug-ins. In Plug-In Name, search for "Welcome Framework" (Plug-in Id is org.eclipse.ui.intro)
 
Robert Heath
Ranch Hand
Posts: 94
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Christophe Verré wrote:

Robert Heath wrote:There is no check box for Welcome.


I almost laughed Before looking for any XML file, it might be that the necessary plugin is not installed.
Go to Help->About Eclipse->Installation Details->Plug-ins. In Plug-In Name, search for "Welcome Framework" (Plug-in Id is org.eclipse.ui.intro)



Thanks Christophe,

Yes, the Welcome Plugin is installed.
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Mmmhh... Which distribution are you using ? Eclipse IDE for Java Developers ? For J2EE Developers ? Something else ?
Also, which perspective are you using ?

If nothing works, maybe a fresh install would solve your problem.
 
Robert Heath
Ranch Hand
Posts: 94
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Christophe Verré wrote:Mmmhh... Which distribution are you using ? Eclipse IDE for Java Developers ? For J2EE Developers ? Something else ?
Also, which perspective are you using ?

If nothing works, maybe a fresh install would solve your problem.



Thanks Christophe,

Actually, I have four installs of Eclipse 3.5.2. Some have the Welcome menu item in the Help Menu; some don't. I considered doing a fresh install, and that is probably what I will eventually do. But I believe that the Welcome item was once in the Help Menu on this install. I just thought I would try to better understand what caused this problem.

Thanks for your help Christophe!
 
Robert Heath
Ranch Hand
Posts: 94
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Robert Heath wrote:

Christophe Verré wrote:Mmmhh... Which distribution are you using ? Eclipse IDE for Java Developers ? For J2EE Developers ? Something else ?
Also, which perspective are you using ?

If nothing works, maybe a fresh install would solve your problem.



Thanks Christophe,

Actually, I have four installs of Eclipse 3.5.2. Some have the Welcome menu item in the Help Menu; some don't. I considered doing a fresh install, and that is probably what I will eventually do. But I believe that the Welcome item was once in the Help Menu on this install. I just thought I would try to better understand what caused this problem.

Thanks for your help Christophe!



I just reinstalled, again. But I checked the "Help" menu immediately, and the Welcome menu item is not there. So it is something that I installed.
 
Robert Heath
Ranch Hand
Posts: 94
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The software install that clobbers the Help Menu is the "Eclipse Platform SDK" install. It creates a menu without the Welcome page.
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Where exactly did you download your Eclipse archive ?
 
Robert Heath
Ranch Hand
Posts: 94
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Christophe Verré wrote:Where exactly did you download your Eclipse archive ?



Christophe,

I am pretty sure that I got it from: http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops/R-3.5.2-201002111343/eclipse-SDK-3.5.2-win32.zip

Thanks
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I wish you could say you're 100% sure Sorry Robert, I'm running out of suggestions. I can't understand why the Welcome menu wouldn't be there either. I tried to download 3.5.2 yesterday, from the same location as yours. The Welcome menu is there. I tried the latest Eclipse SDK 4.0, and the menu is not there, but for a different reason. It's a known issue:

The Intro (Welcome view) is not shown on the start of a fresh workspace. We will need to address the intro management differently in 4.0 than in 3.6. Since this release is targetted at current eclipse developers the expectation is that not having this functionality won't be a major issue.



But for 3.5.2, I have no clue. Check Eclipse logs in case some kind of errors were printed there.
 
Robert Heath
Ranch Hand
Posts: 94
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Christophe Verré wrote:I wish you could say you're 100% sure Sorry Robert, I'm running out of suggestions. I can't understand why the Welcome menu wouldn't be there either. I tried to download 3.5.2 yesterday, from the same location as yours. The Welcome menu is there. I tried the latest Eclipse SDK 4.0, and the menu is not there, but for a different reason. It's a known issue:

The Intro (Welcome view) is not shown on the start of a fresh workspace. We will need to address the intro management differently in 4.0 than in 3.6. Since this release is targetted at current eclipse developers the expectation is that not having this functionality won't be a major issue.



But for 3.5.2, I have no clue. Check Eclipse logs in case some kind of errors were printed there.



Thanks Christophe,

I guess that I was not clear in my description. I believe that this is a bug.

I downloaded the archive over a week ago. I am pretty sure that I got it from eclipse.org. Immediately after I install Eclipse, the Welcome menu item IS in the Help Menu. It is removed after I install the package, "Eclipse Platform SDK", which I reach from Help > Install New Software > All Available Sites > Eclipse Platform SDK. That install removes the Welcome menu item from the Help Menu.

Thanks again!!!
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic