• Post Reply Bookmark Topic Watch Topic
  • New Topic

java.lang.NoClassDefFoundError: org/apache/commons/io/output/DeferredFileOutputStream

 
alsoumahi alBatal
Ranch Hand
Posts: 110
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi guys , I have this error
java.lang.NoClassDefFoundError: org/apache/commons/io/output/DeferredFileOutputStream

I have put all jars commons-io-1.0 , commons-io-1.2 , commons-io-1.4 in the /WEB-INF/lib and also put these jars in the jdk1.6.0_03\jre\lib\ext

but no way still I have this error why!!!

thanks in advance
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65530
108
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Take them out of ext; they don't belong there.

Are you sure you put them in the right WEB-INF/lib? (it happens?) Have you restarted the application? Did you inspect the jar files to make sure the class is really in there?
 
Vikas Kapoor
Ranch Hand
Posts: 1374
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Do you really need all three versions of same jar?
 
Hebert Coelho
Ranch Hand
Posts: 754
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You must check too if your jar files are not corrupetd.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
As mentioned, do *not* put three versions of the same jar on the classpath--you're basically saying "pick an implementation from one of these at random" unless you are *tightly* controlling your deployment, which... is unlikely.

Cargo cult programming is NOT a good idea. Have a reason for what you do.
 
alsoumahi alBatal
Ranch Hand
Posts: 110
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
okey thanks it works , I was not restarting the tomcat server , after putting jar in jdk1.6.0_15\jre\lib\ext , so it works with version 1.0 thanks a lot guys
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65530
108
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Look in the jars!
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's been in commons-io since 1.0; it's more likely you're having a deployment issue.
 
alsoumahi alBatal
Ranch Hand
Posts: 110
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
millions thanks to you guys
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!