• Post Reply Bookmark Topic Watch Topic
  • New Topic

How to configure hibernate in weblogic 10.3.2  RSS feed

 
chu the son
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I try to configure hibernate 3.3.1 in weblogic portal 10.3.2 but seem it's not work.

I added :
- log4j.jar
- hibernate-annotations.jar
- hibernate3.jar

in WEB-INF/lib folder. Then i config commons-logging.xml with value rg.apache.commons.logging.LogFactory = org.apache.commons.logging.impl.Log4jFactory

It can be generate code from database but when i try to develop portlet and create sessionFactory = new AnnotationConfiguration().configure().buildSessionFactory();

So it throw error : Initial SessionFactory creation failed.java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory

I think the problem is in log4j and configuration in commons-logging.xml but i don't know the way to solve this problem. Help me please, thanks in advance!
 
Devaka Cooray
Marshal
Posts: 5624
748
Chrome Eclipse IDE Google App Engine IntelliJ IDE jQuery Postgres Database Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"chu the son", please check your private messages regarding an important administrative matter.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well, the error message sums it up: it's using slf4j, which is not the same as log4j.
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!