• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Bear Bibeault
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Jj Roberts
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Himai Minh
  • Carey Brown
  • salvin francis

HTTP Status 500 - No action instance for path

 
Ranch Hand
Posts: 75
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I am getting 500 error. while executing struts application.
I have checked if action class is public , action method is public, my struts has right configuration but nothing helped. Am I missing anythig else here? following is my code



Any help will be appreciated. Thanks

 
Author
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Check the logs. 500 is an internal server error, which could mean a startup error, a runtime error, etc.
 
Shilpa Tendulkar
Ranch Hand
Posts: 75
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the reply. Log say (AutoGroupsViewAction )action class not found. but I can see it is in the build and at the right path..
dont know what else to look for

 
David Newton
Author
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is it deployed?
 
Shilpa Tendulkar
Ranch Hand
Posts: 75
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yes it is deployed and i can see it in the war file. also I have redeploy the whole applications. its still the same
 
David Newton
Author
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Post the deployed WAR file structure (just the relevant parts).
 
Shilpa Tendulkar
Ranch Hand
Posts: 75
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I just realised when I renamed the action class from AutoGroupsViewAction to AutogroupsViewAction, it works fine...

i have other action classes with has camel case in their names. Also I remember renaming this class from Autogroup... to AutoGroup.. but I also remember this was working for sometime after renaming it to AutoGroup....


I dont know what could have gone wrong..
 
reply
    Bookmark Topic Watch Topic
  • New Topic