• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

SSO connection issue

 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am using SSO for launching my application through NTLM authentication. I have configured SSO wih OpenSSL configuration.

After configuration we have been able to launch application perfectly, but when I launch the applet part of the code the 401 error occurs.

We are making connection from applet to interact with http Servlet by using java.net.URL class.
eg:
URL url = new URL("https", "my server ip", -1, /test?test.do);

HttpURLConnection conn = (HttpURLConnection)url .openConnection();

The connection always return the status code "401" Unauthorized request.

The same code works fine when I did without configuring with SSO.

Please help me on this issue. This is very urgent for me to deliver the product.

Thanks for your help in advance.

Regards,
D.N
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic