• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Maven xml-api dependency

 
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi
I'm having a problem getting the correct xml-apis.
I am alwasys getting the xml-apis-1.0.b2.jar even having in my pom explicity that I want to use the 2.0.2 version of it.


The problem is that in the implementation that they have for the org.w3c.dom.Element they don't have implemented all the methods as with the implementation that comes with the java 1.6.0_11 jdk that I have installed. Thus the function bellow doesn't work because the version 1.0.b2 doesnt have the method setTextContent implemented and the compilation fails.

Is it there any way of changing this to force it to use the 2.0.2 version? Or if not to use the api that comes with the jdk



Thanks
 
author
Posts: 3285
13
Mac OS X Eclipse IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Have a look at the dependency graph to see where 1.0.2 is being pulled in from.
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic