[Logo]
Forums Register Login
Removing JBoss default page
Hi....
I am trying to remove JBoss default page. I removed JBoss\jboss-5.1.0.GA\server\default\deploy\ROOT.war folder and added jboss-web.xml with
<jboss-web>
<context-root>/</context-root>
</jboss-web>
I am getting my application home page when I run run.bat file.
But when i tried JBoss as windows service I am getting error page. Is it anything I need to change while using JBoss as windows service to get my application home page as default page?
Sham, welcome to JavaRanch

Sham Phadtale wrote:Hi....
But when i tried JBoss as windows service I am getting error page.

What's the error code/page?

Is it anything I need to change while using JBoss as windows service to get my application home page as default page?


How did you install JBoss AS as a service? And what params are you passing to the service while starting? Are you sure you are starting the correct JBoss AS "default" configuration?
Thanks Jai.
When I typed http://localhost I get -
Internet Explorer cannot display the webpage
When I typed http://<serverIp>; - Explorer waits for page long time and remain in waiting.

I am using wrapper to run jboss as window service. It works fine by removing above change. I have passed some classpath variables(wrapper.jar, Java home), memory usage parameters.
How did you go about setting up JBoss AS to run as a service? My guess is that the service failed to start, but not knowing which mechanism you used, it is hard to help you.
Hi Peter i am facing a same kind of problem.

I have 2 wars deployed ABC and DEF and removed ROOT.war from JBOSS501GA folder.

For ABC.war i have <context-root>\<context-root> and for DEF it is <context-root>\DEF<context-root>

but when i am hitting http://server/ it gives me a 404 page error and when i hit http://server/DEF it does takes me to the second application

I need to redirect default page to my ABC war

Please note that i am using an Apache layer and have set up virtual ip for my second application DEF in http.conf file. I dont think apache have anything to do with the problem. I Just cannot figure it out.

~Aman
aman, welcome to Java Ranch, but please do not double-post - it wastes everyone's time and also makes having a comprehensive discussion difficult.
http://www.coderanch.com/t/540379/JBoss/Remove-Jboss-home-page-GA
Wink, wink, nudge, nudge, say no more ... https://richsoil.com/cards



All times above are in ranch (not your local) time.
The current ranch time is
Nov 22, 2017 08:17:12.