Forums Register Login
Duplicate PageSettingsBlock record (sid=0x89c) in POI API 3.6.
I am in a real fix and not sure what to do. In our application we store the excel file as clob in the database.
Now to upload or download we use POI in our application.Our code is like this :-

Only workaround that I got from several blogs is to resave the excel file. But unfortunately it is not possible in our case as there are too many files.
Please let me know if there is any workaround in the code to solve this issue for now.
Also let me know if more information is required. Thanks in advance!!!
This was a POI 3.6 bug and was fixed in POI 3.7. So my issue is solved now.

But there on more issue with formula, where its giving !#REF! error. Same was working fine with POI 2.5 in our application.
Is this another bug.Is there any workaround. Please help.
Thanks in advance!!!
Is the reference for a cell in a sheet that exists and is accessible?
Thanks for the reply.

Yes...and when I am using old POI 2.5, the values are being populated but with POI 3.6 and POI 3.7 the problem occurs.
So this shows that reference exists and accessible.

Hi Lester,
Please let me know if you need more information. I need to resolve this issue ASAP .
Ha ha... I have it my friend...but my client is furious :P ..
But sorry if I was too impatient...
Never mind,
One more thing that I can give is the formulas :
='Proposal Shell'!C35

These values get evaluated when I use POI 2.5. Error comes for 3.6 or 3.7.
Thanks again!!!
I think you're going to have compatibility issues between POI 2.5 and 3.6/3.7. Have you tried taking elements out of the formula to see what could be triggering the error?
Can you please elaborate what do you mean by compatibility issues?
3.6 indicates a major version change over 2.5, chances are the formula handling in POI has changed. It may be a bug but it also ma be a deliberate change.
I seem to recall that there were changes in POI 3.5 and newer with respect to accessing external files. I suggest to start with a very simple example, and see if you can get that working. Also check the javadocs to see if there are any methods that look like they might be related to that. And, of course, search online for issues regarding external file references.
Thanks Lester.
I will let all know when my issue is resolved.
Wink, wink, nudge, nudge, say no more ... https://richsoil.com/cards

This thread has been viewed 2320 times.

All times above are in ranch (not your local) time.
The current ranch time is
Feb 24, 2018 09:01:29.