• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Unable to access tomcat5.5.30 using IP Address[but still able to access using http://localhost:8080]

 
Nikhil Chandran
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear All,

We upgraded our tomcat server to 5.5.30.
Everything works fine and we were able to access tomcat home page using the url as - http://localhost:8080 .
But the things went wrong when we tried to use the system ipaddress or loop back ip (http://<server-ipaddress>:8080 or http://127.0.0.1:8080) .
At that time we were getting Server not found error.


Another interesting fact is that it is working fine using both local and loopback ipaddress
in our older version of tomcat(5.0.2)

Due to this problem we were not able to publish the url. Could anyone suggest some possibilities for this problem.

Any help is highly appreciated.

Thanks in advance
NikhilChandran.
 
Tim Holloway
Saloon Keeper
Pie
Posts: 18277
56
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Something is wrong here. "localhost" is an alias for 127.0.0.1. If one or the other should be broken, it should be "localhost".

You didn't mention which OS you're using. It makes a big difference, but no commonly-used OS should be having problems locating 127.0.0.1.
 
Nikhil Chandran
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using windows XP.

Thanks,
NikhilChandran.

 
Nikhil Chandran
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
But it is working fine using both local and loopback ipaddress
in our older version of tomcat(5.0.2) . in same OS, with all environments same
 
Misha Ver
Ranch Hand
Posts: 470
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Nikhil, check firewall and anti virus software setting.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic