Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat 6 as a service

 
Fred Artes
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a problem starting tomcat 6 as a service on my windows server 2003 !

Tomcat starts correctly launching startup.bat !!
startup.bat install install correctly tomcat 6 as a service but when I run it I have this error

TestMessageResource:error=\tomcat6.0\webapps\test\properties\TestMessageResources_it.properties (The system cannot find the path specified)

Path is correct !!!

Please help
 
Misha Ver
Ranch Hand
Posts: 470
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It sounds more like a problem with your application "test". Have you tried to start Tomcat without deploying this app?
 
Fred Artes
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Misha Ver wrote:It sounds more like a problem with your application "test". Have you tried to start Tomcat without deploying this app?


I can see tomcat administration page with my application running !
The SAME application works perfectly when I start manuallt tomcat with startup.bat, so I dont' think it is an application problem !!



NOTE : I have many instances of tomcat on my machine. For this instance I changed port number in server.xml

1) <Server port="8008" shutdown="SHUTDOWN">
2) <Connector port="8085" protocol="HTTP/1.1" connectionTimeout="20000" redirectPort="8445" />
3) <Connector port="8011" protocol="AJP/1.3" redirectPort="8445" />
 
Fred Artes
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If I put a testApplication.rar in webapps folder and start tomcat, rar file is not unzipped
 
Han Jie
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi Fred

Maybe you can remove your windows service of tomcat6 and re-register it.

And i want to ask you that other file tpes can be deployed in webapps and it is unzipped except *.war?
 
Fred Artes
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Han Jie wrote:hi Fred

Maybe you can remove your windows service of tomcat6 and re-register it.


I have done service.bat uninstall and service.bat install but nothing

Han Jie wrote:
And i want to ask you that other file tpes can be deployed in webapps and it is unzipped except *.war?


Ops, I'm a stupid
 
leo donahue
Ranch Hand
Posts: 327
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you are using the zip version of tomcat...

cd to the tomcat bin directory.

issue this command: service install Tomcat6

That should install Tomcat as a windows service.
 
Fred Artes
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No, same problem

I don't understand, Tomcat examples application work correctly. Only my application has problems ! But why it works fine if I start Tomcat using startup.bat ?

This is my server.xml

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic