This week's book giveaway is in the OO, Patterns, UML and Refactoring forum.
We're giving away four copies of Five Lines of Code and have Christian Clausen on-line!
See this thread for details.
Win a copy of Five Lines of Code this week in the OO, Patterns, UML and Refactoring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Issue running TLD

 
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am running first tld example in HF Servlet and JSP book and I am getting "The requested resource () is not available"
messgage.

These are the programs
JSP



TLD



JAVA



web.xml


Put all the files in correct folders as book mentioned and its not working.
Can someone please be able to help?

On side not : If someonce else asked the same question before and if someone knows the place I can find answer , please direct me.
I have done a search in whole forum and didn't came across anything this basic being asked.

Thank you
 
Ranch Hand
Posts: 310
1
Oracle Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I see a typo in your web.xml Please correct it and see


Which URL are you using to access the servlet? Are you using Tomcat?
 
Creator of Enthuware JWS+ V6
Posts: 3348
303
Android Eclipse IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Jade,

Apart from the typo that Rajeev is mentioning

Change the following:

into

and in the web.xml

into

Then it should work

Regards,
Frits
 
Jade Lucky
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks you very much.I will give it a try
 
Jade Lucky
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Thanks for the help.
I have done a another typo error of not defining a jsp libarary.

after i changed my tld file like this it worked

<taglib xmlns="http://java.sun.com/xml/ns/j2ee";
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance";
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-jsptaglibrary_2_0.xsd"
version="2.4">
 
Don't get me started about those stupid light bulbs.
    Bookmark Topic Watch Topic
  • New Topic