• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Command is not showing in to the list on pressing menu button on the device

 
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Everyone,

I have developed a midlet in which I have designed buttons or links using Custom Items. Command associated with the custom item is not showing in to the list on pressing menu button on the device 8300 Curve.

For example - My login screen have SUBMIT and RESET custom items. I have designed them to be appear like links [no matter how I design them]. I have also added a command and listener to it like as below:

CMD_SUBMIT = new Command(text, Command.ITEM, 1);
setDefaultCommand(CMD_SUBMIT);
setItemCommandListener(this);

On running the midlet, my login screen appears. But when I traverse to the SUBMIT item, and press the menu button, my command doesn't appear in the list of commands. It shows only the Close command. I am not getting why this is happening.

Please do me a favor and help me to sort out this. On other phones like 8520 curve the command is appearing in to the list when I press the menu button.

Regards
 
author
Posts: 26
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I don't see anything wrong with the code. The fact that it works on some devices and not others is quite interesting -- it may be that the handset has a bug. Does the same handset have problems with adding commands to other Items?
 
Nikhil Shravane
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks Carol,

I also think that the device has a bug. I tested the same code on almost 12 recent devices. Out of those, on 10 it is showing the selected command in to the list of commands on pressing the menu button. But on 8300 and I found one more... 8110, it is not showing in to the list. Both of these are quiet old devices.

8300 launched in the beginning of the 2007.
8110 launched in the beginning of the 2008.

What might be the problem? Is there any link which states that there is a bug in these two phones? So that I can show it to my senior? Any help would be greatly appreciated. Best Regards.

reply
    Bookmark Topic Watch Topic
  • New Topic