• Post Reply Bookmark Topic Watch Topic
  • New Topic

configure java version 1.3 should be used in a jre 1.5  RSS feed

 
nimo frey
Ranch Hand
Posts: 580
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
where can I set the java version which should be used for my application?

I have java 1.6 installed, but want to run it in java 1.3 version. I need something like:

java -run in version 1.3 and not in 1.5

Can I do this in any way? Can I provide a property file?
 
Campbell Ritchie
Marshal
Posts: 56525
172
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Why on earth do you want to use a 10-year old JVM?

Go and find the documentation for the "java" and "javac" tools; there are flags for source and target types.
 
nimo frey
Ranch Hand
Posts: 580
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
okay found:

http://publib.boulder.ibm.com/infocenter/realtime/v1r0/index.jsp?topic=/com.ibm.rt.doc.10/user/specifying_options.html



runs the jre in version 1.3.
 
nimo frey
Ranch Hand
Posts: 580
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Why on earth do you want to use a 10-year old JVM?


A good question

I have an example application which (oddly) runs only in jre 1.3.
 
Campbell Ritchie
Marshal
Posts: 56525
172
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
nimo frey wrote:okay found: . . .
I didn't know about that IBM page. I have only ever used the Oracle versions. Note that link is far the Windows version of the "java" tool; you should find it easy enough to find the javac tool by altering the link.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!