Win a copy of The Way of the Web Tester: A Beginner's Guide to Automating Tests this week in the Testing forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Session not bound?

Maja Gralewska
Ranch Hand
Posts: 92
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Iv got this weird problem with my deploy, normally the .jar is about 12KB, code has not been removed only added. The size of the .jar now is about 9KB

The basic structure of the program is Project->Packages->,,,,

The Session & SessionHome for the sessionBean are generated by the xdoclet and put in a separate package called interfaces.

The complete process consists of 4 steps as follows:

1) xdoclet (creates the sessions)
2) refresh & clean
3) package (build)
4) deploy (signer)

I get multiple errors of the following(for different sessions) when I run the xdoclet:

[org.jboss.ejb.plugins.local.BaseLocalProxyFactory] TariffedInvoiceLineExStoreSession cannot be Bound, doesn't have local and local home interfaces...

The session does exist and is created successfully.

Here is the xdoclet:

Any ideas on what the problem could be? The code does not contain any errors either.

I have tried stopping jboss & restarting as well as the server & eclipse.

Thanks for your help.

  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic