Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

"jsessionid=..." occassionally appears on my URL and sometimes I don, is that a bug ?

 
Artemesia Lakener
Ranch Hand
Posts: 162
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have checked my browser by using "isREquestedSessionIDFromCookie()" method and it returns TRUE so my browser is supporting cookies. Now the confusing part is -- Sometimes I don't see any "jsessionid=xxxx" but sometimes I see "jsessionid=...", it looks like quite arbitrary, sometimes on this page I see it, but not on next page, and vice versa, the application works fine though. I am wondering if anybody knows the reason for this. Is this a bug coming from my application ? But I really don't do any session tracking here as struts handles that for me.
 
Artemesia Lakener
Ranch Hand
Posts: 162
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The interesting thing is even after I block the cookies on my browser, when I get to the beginning JSP page, first I saw "jsessionid=.." when clikc "submit" to go to the next page, but when I click "back" to the first page, and then click "refresh" button, then click the submit, this time the "jsessionid=..." disappeared. why ? AM I supposed to see it because I have blocked the cookies ??
 
Tokunbo Oke
Ranch Hand
Posts: 57
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This is perfectly normal. Read page 66 of Struts in Action, Husted et al (in any bookshop) for details.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic