• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Bear Bibeault
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Jj Roberts
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Himai Minh
  • Carey Brown
  • salvin francis

how to debug log4j

 
Ranch Hand
Posts: 44
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
we use log4j with our application.Our log4j stopped creating logs , the same log4j works when I deploy in my local weblogic server , here code for my log4j


this same log4j is working fine in my local weblogic in windows , but not in weblogic from unix box my staging server, please suggest how can debug this ? can unix box stop new logs from getting created ? Please suggest me how to debug this
 
Rancher
Posts: 618
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does your directory /u01/oracle/logs/artms/ exist and does it have the correct permissions to write to it? Is your weblogic log files showing any errors?
 
sam bartl
Ranch Hand
Posts: 44
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Tom Reilly wrote:Does your directory /u01/oracle/logs/artms/ exist and does it have the correct permissions to write to it? Is your weblogic log files showing any errors?



Yes it has the directory and it used to write before , it stopped all of sudden , we tried restarting the server but it does not write any new logs, weblogic did not show any erros.
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic